티스토리 뷰

몇 번째인지 모르겠지만 맥북과 iMac을 사용하다 운영체제를 업그레이드 한 이후 git을 사용할 때 다음과 같은 에러가 발생했다.

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

최근에는 카탈리나(Catalina) 버전으로 업그레이드 한 이후 위 에러가 발생했다.

$ git --version
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

 

운영체제를 업그레이드하면서 Xcode Command Line Tools 관련하여 뭔가 문제가 발생하는 것 같았다. Xcode를 사용하고 있지 않아서 의아했지만 매번 간단한 방법으로 해결하고 있다.

 

해결 방법

해결방법은 간단하다. 

xcode-select --install

다시 설치하면 된다.

$ git --version
git version 2.21.0 (Apple Git-122.2)

 

TAG
댓글
댓글쓰기 폼
공지사항
Total
41,245
Today
54
Yesterday
285
링크
«   2020/11   »
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30          
글 보관함